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Abstract 
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Macropinocytosis is an evolutionarily conserved process, which is characterized by the formation of membrane 
ruffles and the uptake of extracellular fluid. We recently demonstrated a role for CYFIP-related Rac1 Interactor 
(CYRI) proteins in macropinocytosis. High-molecular weight dextran (70kDa or higher) has generally been used as 
a marker for macropinocytosis because it is too large to fit in smaller endocytic vesicles, such as those of clathrin 
or caveolin-mediated endocytosis. Through the use of an image-based dextran uptake assay, we showed that cells 
lacking CYRI proteins internalise less dextran compared to their wild-type counterparts. Here, we will describe a 
step-by-step experimentation procedure to detect internalised dextran in cultured cells, and an image pipeline to 
analyse the acquired images, using the open-access software ImageJ/Fiji. This protocol is detailed yet simple and 
easily adaptable to different treatment conditions, and the analysis can also be automated for improved processing 
speed. 
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Background 
 
Cell migration is one of the many fundamental processes that occur during normal development and physiology 
(Theveneau and Mayor, 2013; Krause and Gautreau, 2014). Central to this process is the main plasma membrane 
branched actin generating module, comprising of four main components: the small GTPase protein Rac1 (Machacek 
et al., 2009), the Scar/WAVE complex (Davidson and Insall, 2011; Krause and Gautreau, 2014), the Arp2/3 complex 
(Goley and Welch, 2006), and actin. When cells receive a stimulus, such as a growth factor or chemo-attractant, 
these molecules and complexes work together to nucleate the branched actin network and push the plasma 
membrane forward, promoting cell migration. Interestingly, macropinocytosis (Swanson and Watts, 1995; 
Bloomfield and Kay, 2016), an evolutionarily conserved endocytic process, shares the same molecular machinery 
as cell migration. However, instead of pushing in the plane of the front-rear axis of the cell, local actin 
polymerisation pushes plasma membrane sheets forward or upward, to form cup-like structures that resolve into 
macropinocytic vesicles taken into the cell. Cells use macropinocytosis not only to uptake nutrients but also to traffic 
and organize different membrane receptors, such as integrins, to modulate their adhesion and invasion in cancer (Le 
et al., 2021).  
  In our recent paper published in the Journal of Cell Biology (Le et al., 2021), we utilised an image-based 
internalisation assay, to show that cells lacking CYFIP-related Rac1 Interactor (CYRI) proteins displayed a reduced 
macropinocytic uptake of dextran 70 kDa. 
  In this Bio-Protocol article, we describe a step-by-step protocol to detect and quantify the amount of dextran 
uptake in cultured adherent cells. The wet lab procedure is inspired by Commisso (Commisso et al., 2014), with 
modifications to simplify the method. We tried different types of dextran, including dextran tetramethylrhodamine 
(TMR) (Invitrogen, #D1818), dextran Texas Red (Invitrogen, #D1830), and dextran Fluorescein (Invitrogen, 
#D1822). We found only the last type resulted in clean and analysable data without the need for excessive washing, 
while both the dextran TMR and dextran Texas Red resulted in a high background with visible clumps of protein, 
even after multiple washes. We also omit the overnight starving steps, as we found that they were not essential and 
made no difference to the outcome, using our conditions and cells. This significantly reduced the length of time 
required for the assay. Since the method described here has been used quite commonly and successfully in the 
literature before, we focus more on simplifying the experimentation steps and improving the automation capability 
in the quantification step. We provide the full macro script that can be directly copied and pasted into your Macro 
window in ImageJ/Fiji (Schindelin et al., 2012). We also provide comments to explain in simple terms what each 
command in the script does, which could be very useful for those who have no background in coding, or who have 
just started their journey in programming. We believe this is something that is still missing in the current literature, 
where there are a lot of resources for image analysis, but many are not necessarily accessible or presented in 
understandable terms for everyone, particularly beginners. The image analysis pipeline presented here is also 
suitable for analysing any other intracellular signal, including but not limited to integrin internalisation (Le et al., 
2021), transferrin, and other endocytic processes.  
 
 

Materials and Reagents 
 
A. Cell culture 

1. Aluminium foil 
2. Parafilm 
3. Paper towel or absorbent tissue 
4. pH test strips, pH-Fix 0–14 PT, fixed indicator (Macherey-Nagel, catalog number: 92111) (optional) 
5. 12-well culture plate (Falcon, catalog number: 353043) 
6. 15-cm tissue culture dish with grid (Fisher Scientific, FalconTM 353025, catalog number: 10314601) 
7. 15-mL conical tubes (Fisher Scientific, FalconTM 352196, catalog number: 11507411) 
8. 19-mm glass coverslips (VWR, catalog number: 631-0156) 
9. COS-7 cells (ATCC, catalog number: CRL-1651) 
10. DMEM (Gibco, catalog number: 21969-035), store at 4°C 
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11. L-Glutamine (Gibco, catalog number: 25030-032), store at 4°C 
12. 2.5% Trypsin, no phenol red (Gibco, catalog number: 15090046), store at 4°C 
13. Penicillin-Streptomycin (LifeTechnologies, catalog number: 15140122), store at 4°C 
14. Fetal Bovine Serum (FBS) (Gibco, catalog number: 10270-106), store at 4°C 
15. PE buffer (see Recipes, store at room temperature) 
 

B. Chemicals 
1. Fibronectin, Bovine Plasma (Sigma-Aldrich, catalog number: F1141), store at 4°C 
2. 16% paraformaldehyde (Electron Microscopy Sciences, catalog number: 15710), store at room 

temperature 
3. ProLong Diamond antifade mounting medium (Invitrogen, catalog number: P36961), store at   -20°C 
4. Hoechst 33342 (Thermo Scientific, catalog number: 62249), store at 4°C 
5. Dextran, Fluorescein, 70,000 MW, Anionic, Lysine Fixable (Invitrogen, catalog number: D1822), store at 

4°C, avoid direct light exposure (see Procedure A) 
6. 70% Nitric acid (Sigma-Aldrich, catalog number: 225711), store at room temperature 
7. Ethanol ≥99.8%, (absolute alcohol, without additive) (Sigma-Aldrich, catalog number: 51976), store at 

room temperature 
8. EDTA (Fisher Scientific, catalog number: 10289410) 
9. Distilled water 
10. PBS buffer tablets (Fisher Scientific, catalog number: 10209252), store at room temperature 
11. PBS buffer (see Recipes) 
12. PE buffer (see Recipes) 
13. Growing DMEM medium (see Recipes) 
14. Serum-free DMEM medium (see Recipes) 
15. 4% PFA solution (see Recipes) 
 
 

Equipment 
 
1. Small metal tweezers 
2. A homemade incubating chamber 
3. Haemocytometer or cell counter 

 
 

Software 
 
1. Zeiss LSM 710 confocal microscope system (or any other common confocal system if available) 
2. ImageJ or Fiji v2.3.0/1.53m 
3. GraphPad Prism 7 
 
 

Procedure 
 
The following procedure is based on the experimental conditions that we used to dissect the role of CYRI proteins. 
A typical experiment should contain at least two incubation timepoints for dextran: 15 and 30 min. Each time point 
should be done in a separate 12-well plate. Each plate should at least contain one coverslip for scramble control, 
and one coverslip for each CYRI siRNA-treated sample (minimum of two independent siRNA). You can include 
other conditions and controls, such as EIPA (a Na+/H+ inhibitor) (Koivusalo et al., 2010), or LY294002 (a PI3-K 
inhibitor), depending on your experimental setup. The following protocol is described for one coverslip as an 
example, but this should be scaled up appropriately, depending on your experimental conditions. Any step that deals 
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with cell seeding or matrix coating has to be done inside a biological tissue culture hood. Construction of the 
incubation chamber and performing the dextran uptake assay can be done outside of the tissue culture hood.  
 
A. Making an incubating chamber (Figure 1A) 

 
This step can be done outside of a biological tissue culture hood. 
1. Use a 15-cm tissue culture dish and cover the outer surface of both the plate and the lid with aluminium 

foil. 
2. Cut a 9 cm × 9 cm piece of parafilm, and place it in the bottom of the dish. 
3. Disinfect the plate with 70% ethanol. 
 

 
 
Figure 1. Making a homemade incubating chamber.  
A. A homemade incubating chamber made out of a 15-cm tissue culture plate covered in aluminium foil. The 
dotted red line indicates the parafilm placed inside the dish. B. Wet tissue is placed around the edge of the 
incubating chamber before closing the lid to prevent dehydration of the coated coverslips. 
 

 
 

!NOTE: Construction of the chamber can be done outside of the tissue culture hood. But be sure to spray 
and wipe the chamber with 70% ethanol, to disinfect it before using it inside a tissue culture hood. 
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B. Preparing acid-treated glass coverslips 
 
This step must be performed in a chemical hood. 
1. Place 19-mm glass coverslips in a 400-mL glass beaker. 
2. Carefully pour 70% nitric acid into the beaker, until all coverslips are submerged. 
3. Very gently swirl the beaker, to allow the acid to make contact with all of the coverslips. 
4. Leave the coverslips in acid for 30 min. 
5. Safely decant the acid back into another bottle (the acid can be reused), and wash the coverslips multiple 

times with distilled water (50–100 mL each time) for approximately 15 min. 
6. (Optional) Test the pH of the solution, covering the coverslips with a pH strip until it reaches approximately 

pH 7.0. 
7. Pour the water from the beaker away, and replace it with 100 mL of 70–100% ethanol. 
8. Use parafilm to cover the mouth of the beaker, to slow down evaporation. Store the beaker away from 

direct sunlight. The coverslips can be safely stored at room temperature, for as long as the ethanol is still 
present, but note that the ethanol will evaporate over time. 

 

 
 
C. Coating coverslips with fibronectin 

 
This step must be performed inside a biological tissue culture hood. 
1. Disinfect the incubating chamber and tweezers by spraying with 70% ethanol and letting them dry inside 

a tissue culture hood. 
2. Dilute fibronectin in PBS buffer to a final concentration of 10 μg/mL. 
3. For each coverslip, pipette 40 μL of the fibronectin-PBS solution on top of the parafilm previously placed 

inside the incubating chamber. The liquid should form a droplet on the parafilm, due to the hydrophobic 
effect. 

4. Use tweezers to pick up an acid-treated coverslip, quickly wash off the ethanol by dunking it in PBS, and 
gently place the coverslip on top of the fibronectin droplet in the incubating chamber. Do this for as many 
coverslips as you require for your experiment. 

5. To prevent dehydration, dampen some tissues with water, place them around the inner edge of the 
incubating chamber, and make sure they do not touch the coverslips (Figure 1B). 

6. Close the lid, and let the coverslips incubate at room temperature for 1–2 h. 
7. Use tweezers to transfer each coverslip to a well of a 12-well tissue culture plate, and wash them three 

times with PBS. 
8. Block the coverslips by adding 1 mL of DMEM containing 10% serum to each well. Leave them in the 

cell incubator (37°C, 5% CO2) until cell seeding. 
 

D. Seeding cells onto coverslips 
 
This step must be performed inside a biological tissue culture hood. 
1. From a 10-cm tissue culture plate of COS-7 cells at 80% confluency, aspirate off all of the medium. 
2. Wash the cells with 5 mL of PBS. 
3. Add 300 μL of 0.25% trypsin solution, and incubate in the cell incubator (37°C, 5% CO2) for 5 min. 
4. Add 5 mL of 10%-serum DMEM, to quench the trypsin. 
5. Transfer the cell suspension into a 15-mL Falcon tube, and centrifuge at 500 × g for 5 min. 
6. Aspirate off the medium, and resuspend the cell pellet in 5 mL of 10%-serum DMEM. 
7. Count the cells, either by using a haemocytometer, or an automated cell counter. 
8. Calculate the volume of the cell suspension needed to get 50,000 cells per coverslip, using this equation:  

!NOTE: It is important to wash away all the acid before storing the coverslips in ethanol, as concentrated 
nitric acid can react with ethanol to form toxic nitric dioxide (NO2) gas.  
!NOTE: If nitric acid is not available, the coverslips can be prepared by standard autoclaving. 
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𝑉𝑉 =  
50,000
𝐴𝐴

× 1000 (μL) 

V is the volume of the cell suspension (μL). 
A is the concentration of cells in the cell suspension (cell/mL). 

9. For each coverslip, make the volume of the 50,000-cell suspension up with the growth medium to 1 mL, 
and add dropwise to the coverslip. 

10. Incubate the cells at 37°C and 5% CO2 overnight. 
 
E. Dextran uptake assay 

 
1. Make up the dextran solution: 

a. Inside a tissue culture hood, resuspend the dextran powder in PBS to the final concentration of 10 
mg/mL. Make sure as much dextran is dissolved as possible, by pipetting up and down. 

b. Transfer the content into 1.5-mL Eppendorf tubes, and centrifuge in a tabletop centrifuge at 13,523 × 
g for 15 min, to get rid of any undissolved dextran. 

c. Without disturbing the pellet, make 50 μL-aliquots of the dextran solution into smaller tubes, and store 
at -20°C.  
 

This step can be done outside the tissue culture hood. 
2. On the day of the assay, prepare these before starting the assay: 

a. Cooldown the PBS on ice. 
b. Thaw dextran at room temperature, and make sure it is shielded from any light source. 
c. Warm-up serum-free medium in a 37°C water bath until the experiment. 
d. Prepare an ice tray. 
e. Prepare a 4% paraformaldehyde (PFA) solution in PBS in the chemical fume hood. 
 

 
 

3. Take the two 12-well plates containing your cells that have been seeded on coverslips the day before out 
of the incubator, and place them on ice. 
 

 
 

4. Aspirate off the medium and wash the cells three times with ice-cold PBS. 
5. Dilute the dextran in a warm serum-free medium, to the final concentration of 0.2 mg/mL. 

 

 
 

6. Add 1 mL of the dextran solution to each coverslip, and quickly transfer the plates back into the cell 
incubator for 15 and 30 min, respectively.   

7. After the respective incubation time, wash each plate three times with 1 mL of ice-cold PBS, to stop the 
endocytosis process and wash away any excess dextran.  

8. In a chemical hood, add 500 μL of 4% PFA to each coverslip to fix the cells at room temperature for 15 
min.  

!NOTE: PFA is a COSHH3 chemical and is a known carcinogen, so you must take care when working 
with it. 

!NOTE: Cooling down the cells on ice slows down any endocytic processes and allows cells to be 
synchronized for when warm dextran solution is added. From our experience, performing this 
temperature shift gives better internalized-dextran signals. 

!NOTE: The concentration of 0.2 mg/mL was found to be sufficient in our experimental setup. Higher 
or lower concentrations (0.1–1 mg/mL) can be trialled but, from our experience, 0.2 mg/mL gave the 
best signal without using too much resources. 
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9. Pipette out the PFA and dispose of it appropriately according to your institute regulations. Wash the 
coverslips three times with PBS. 

10. Dilute Hoechst in PBS to 2 μM, add 50 μL of this solution to each coverslip, and incubate at room 
temperature in the dark for 30 min. 

11. After 30 min, wash away the excess Hoechst with 1 mL of PBS three times. 
12. Mount the coverslips with 100 μL of mounting medium, and leave them in the dark at room temperature 

to set overnight. 
 

 
 
F. Image acquisition 

 
1. For each coverslip, select ten random fields of view to image. 

 

 
 

2. Adjust focus based on the dextran channel (488 nm) and image a single plane with the 40× objective lens 
of a Zeiss LSM 710 confocal microscope. See Figure 2 for sample images. 
 

 
 
Figure 2. Example images of the dextran uptake assay of COS-7 cells taken with the Zeiss 710 LSM, 40× 
lens microscope system, along with an example quantification.  
The control condition is scramble siRNA, and siRNA condition is the combination of both siRNA targeting 
CYRI-A and CYRI-B. As can be seen, at 15 min of incubation, there is not much difference between the control 

!NOTE: The slides can be stored in the dark at 4°C for at least 1 month without much loss of signal. 
However, we recommend imaging your slides 24 to 36 h after mounting (depending on how fast your 
mounting media solidifies), to obtain the best results. 

!NOTE: To avoid biases and facilitate downstream analyses, the researcher should use the Hoechst 
channel (305 nm) when selecting the ten random fields of view. Select clusters of cells where the nuclei 
are evenly distributed all in one focal plane, and avoid places where they are piling on top of each 
other. 



Cite as: Le, A. H. and Machesky, L. M. (2022). Image-based Quantification of Macropinocytosis Using Dextran Uptake 
into Cultured Cells. Bio-protocol 12(07): e4367. DOI: 10.21769/BioProtoc.4367. 

 

8 
 

 

Published:  Apr 05, 2022 

and the siRNA-treated condition. But after 30 min of incubation, the control cells have taken up significantly 
more dextran compared to the CYRI-A/CYRI-B double knockdown cells. The quantification graph is adapted 
from our original publication (Le et al., 2021), with each colour representing data collected from one replication. 
Error bar = SD. Hoechst = cyan, Dextran = magenta. Scale bars = 20 μm. 

 

 
 

3. The Zeiss software automatically exports images under the .czi file format, but .tiff images are also suitable 
for analysis. 

 
G. Image analysis 

 
1. Manual analysis (Figure 3) 

a. Open the .czi images (or .tiff) in ImageJ/Fiji. 
b. To separate the dextran and Hoechst channels: Image -> Color -> Split channels. 
c. Convert both channels to 8-bit: Image -> Type -> 8-bit. 
d. Duplicate the dextran channel to analyse the internalised dextran signal in one, and measure the 

selected area in the other: Image -> Duplicate… 
e. In one of the dextran images, increase the brightness until the outline of the cells becomes visible: 

Image -> Adjust -> Brightness/Contrast… 
f. Use the Freehand selections tool to outline the selected area for analysis. 
 

 
 
g. Go to Edit -> Selection -> Make Inverse then press the backspace button to delete the background. 
h. To measure the selected area: Image -> Adjust -> Threshold -> Set to 1, 255. This should highlight 

the selected area in red. 
i. Analyze -> Analyze Particles -> Set Size: 0–Infinity, Circularity: 0.00–1.00, Show: Outlines, tick 

Display Results, Summarize and Include holes -> OK. 
j. Transfer the selected region from the first dextran image to the second dextran image by using the 

combination key: Shift+Command+E on Macbook, then press the backspace button to delete the 
background. 

 

 
 
k. To measure the internalised dextran: Image -> Adjust -> AutoThreshold -> MaxEntropy, then analyse 

particles as described in i.  
l. Copy and paste the result into Excel for further statistical analysis (described in the later section). 

!NOTE: Our samples are flat enough after fixation and mounting, so that a single plane of imaging 
was sufficient in our case. For thicker samples or imaging at a higher magnification lens, a z-stack 
with the appropriate interval might be needed. After that, images can be maximally projected into a 
single image and the same analysis applied. 

!NOTE: Steps e and f can also be done more easily if cells are also stained with phalloidin (568 nm) 
to visualise filamentous actin. However, we found this to not be essential in our case.  
!NOTE: Instead of measuring the area covered by cells, we can also count the number of cells in a 
particular field of view, by counting the number of DAPI-stained nuclei. However, this method should 
only be used if the cell spread area is relatively unchanged between the different conditions, which is 
not the case for our CYRI-knockdown cells. 

!NOTE: For a more general command, you can open the ROI Manager in ImageJ/Fiji: Analyze -> 
Tools -> ROI Manager… Here you can click Add, to save your selected region from the first dextran 
image. Then go to the second dextran image, click on the ROI code number of that region in the ROI 
Manager, the selected region will be transferred. This should work for both Macbook and PC. 
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m. Repeat the same procedure for other images.  
 

 

 
 
Figure 3. Dextran analysis workflow with ImageJ/Fiji.  
The dotted arrow denotes the transferring of the region of interest (magenta outline) from one image to the 
other by pressing the combination Shift+Command+E. 

 
2. Semi-automated analysis pipeline using ImageJ/Fiji:  

This section provides the full macro to automate most of the steps described above and can significantly 
increase the processing speed to at least 100-times faster compared to manual analysis. These macro scripts 
have been tested, and used successfully for our analysis. 
Before running these macros, make sure to set up your “Analyse Particles” window, as stated in step 1i in 
the Manual analysis section. 

 
• Step 1: Macro for automatically splitting the two channels, adjusting the brightness, and saving the 

resulting images to a chosen folder. 
 
Before running the macro, have all original images in a folder of any name. This is where your Source Directory 
will be. 
 
Create a second folder of any name outside of the Source Directory. This is where your resulting images will 
be saved to (Output Directory).  
 
To open a new Macro window: Plugins -> New -> Macro 
Copy and paste this macro script into a new Macro window.  
 

 
 
An orange colour with “//” in front denotes comments and will not be included in the code when run. 
If you want to know what each of the steps does, simply add the double dashes “//” in front of all of the steps 
that follow, to exclude them out from the pipeline, or simply copy and paste just one of the command lines into 
a new Macro window, then click Run.  

 

!NOTE: When the macro is running, a popup window for each image may appear, depending on the type 
of image file, click OK to continue. 
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//Choose the folder (Source Directory) where your original images are 
stored. 
selectedFolder = getDirectory("Choose Source Directory ");  

 
//the getFileList function returns an array of all the file names present 
in the selectedFolder. 
fileList = getFileList(selectedFolder);  

 
//the lengthOf function counts the number of files in the fileList array 
(which, by extension, is in the Source Directory). 
numFiles = lengthOf(fileList);  

 
//Choose the folder where the exported images are to be saved. 
saveloc = getDirectory("Choose Ouput Directory");  

 
//This is optional, but you can print out the number of files from the 
Source Directory folder, as a way of checking if the code is working. A 
window will pop up, showing the number of files. 
print(numFiles)  

 
//BatchMode automatically turns off any open image window to avoid 
cluttering. You can turn this off too. 
setBatchMode(true);  

 
//This whole block below is an iteration command that will go through each 
file in the Source Directory, convert the images to 8-bit, adjust their 
brightness, and save them in your selected folder. 
for (i=0;i<numFiles;i++) {  
 file = fileList[i];  
 open(selectedFolder + file);  
//Make sure to untick the Split Channels option for multichannel images, 
in the Bio-Formats Import Option popup window, before the next command. 
Then, press Enter to continue. 
 run("Split Channels");  
 selectWindow("C2-" + file);  
 run("8-bit"); 
 run("8-bit");  
 rename("1"); //Rename the image to easier select window later on 
 run("Duplicate...", " "); 
 selectWindow("1-1"); 
 run("Brightness/Contrast..."); 
 setMinAndMax(0, 20); 
//Save images with a prefix “Area_” or “Dextran_” appended to the original 
file name. 
saveAs("Tiff", saveloc + "Area_" + file);  
 selectWindow("1"); 
 saveAs("Tiff", saveloc + "Dextran_" + file);  
 run("Close All"); 
} 
 
• Step 2:  
This is the only manual step. 
Now that all your processed images are saved into your output folder, open the images with “Area_” prefix in 
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their name, repeat steps 1f and 1g in the Manual analysis section, and use step 1j to transfer the selected region 
of interest from the “Area_” images to the images with “Dextran_” prefix in their name.  
Save the newly processed images into a new folder called “Area” and “Dextran”, respectively.  
If phalloidin staining was included, cells can be automatically segmented and this step can be automated. 
 

 
 

• Step 3: 
Macro for measuring the area of the selected region. 
Copy and paste this macro into a new Macro window and click Run. 
When this macro finishes running, a Results file containing the measurements will be saved to the selected 
Output Directory. 

 
//Choose the “Area” folder as your Source Directory. 
selectedFolder = getDirectory("Choose Source Directory");  
 
fileList = getFileList(selectedFolder);  
 
numFiles = lengthOf(fileList);  

 
//Choose the same “Area” folder as your Output Directory. 
Saveloc = getDirectory("Choose Output Directory");  
 
setBatchMode(true);  

 
//This whole block below is an iteration command that will go through each 
file in the Source Directory, measure the area of the selected region, and 
export the results as a csv. file to the “Area” file. 
for (i=0;i<numFiles;i++) {  
 file = fileList[i]; //Indexing the file from 0 to i. 
 open(selectedFolder + file); 
 setAutoThreshold("Default dark"); 
 run("Threshold..."); 
 setThreshold(1, 250); 
 run("Analyze Particles...", "  show=Outlines display summarize"); 
 selectWindow("Results"); //This selects the Results window 
//This saves the Results file to the folder called "Area" 
 saveAs("Results", "/Users/ale/Desktop/Area/Results.csv");  
 run("Close All"); 
} 

 
• Step 4:  
Macro for measuring the internalizedsed dextran. 
Copy and paste this macro into a new Macro window and click Run. 
When this macro finishes running, a Summary file containing the measurements will be saved to the selected 
Output Directory. 

 
//Choose the “Dextran” folder as your Source Directory. 
selectedFolder = getDirectory("Choose Source Directory");  
 

!NOTE: The saving step can be automated too. You can record the steps using a macro recording window: 
Plugins -> Macro -> Record… 



Cite as: Le, A. H. and Machesky, L. M. (2022). Image-based Quantification of Macropinocytosis Using Dextran Uptake 
into Cultured Cells. Bio-protocol 12(07): e4367. DOI: 10.21769/BioProtoc.4367. 

 

12 
 

 

Published:  Apr 05, 2022 

fileList = getFileList(selectedFolder);  
 
numFiles = lengthOf(fileList);  

 
//Choose the same “Dextran” folder as your Output Directory. 
saveloc = getDirectory("Choose Output Directory");  
 
setBatchMode(true);  

 
//This whole block below is an iteration command that will go through each 
file in the Source Directory, measure the internalizedsed Dextran signal, 
and export the Summary file as a csv. file to the Dextran folder. 
for (i=0;i<numFiles;i++) {  
 file = fileList[i];  
 open(selectedFolder + file); 
//Apply MaxEntropy AutoThreshold to images 
//You can use a different AutoThreshold other than MaxEntropy, depending 
on your image acquisition. 
 run("Auto Threshold", "method=MaxEntropy white");  
 run("Threshold..."); 
 setThreshold(255, 255); 
 run("Analyze Particles...", "  show=Outlines display summarize"); 
 run("Close All"); 
} 
selectWindow("Summary"); 
saveAs("Results", "/Users/ale/Desktop/Dextran/Summary.csv");  
//The last two commands are outside the "for" loop, to allow all the Summary 
results to be put into the same window and therefore saved all at once. 

 

Data analysis 
 
Once you have analysed all of the images and obtained the area of the region of interest, as well as the area of the 
dextran signal, we can calculate the internalisation index by using the formula: 
 

𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼 𝐼𝐼𝐼𝐼𝑖𝑖𝐼𝐼𝑖𝑖 =  
𝐷𝐷𝐼𝐼𝑖𝑖𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼 𝐼𝐼𝐼𝐼𝑠𝑠𝐼𝐼𝐼𝐼𝐼𝐼

𝐴𝐴𝐼𝐼𝐼𝐼𝐼𝐼 𝐼𝐼𝑜𝑜 𝐼𝐼𝐼𝐼𝑠𝑠𝐼𝐼𝐼𝐼𝐼𝐼 𝐼𝐼𝑜𝑜 𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼𝐼
 

 
Plot the internalisation index using the appropriate software, such as Graphpad Prism. At least three independent 
biological replicates (separate experiments are repeated at least three times on three separate days) are performed 
before analysing. You can also include technical replicates for each tested condition within each biological replicate, 
based on your hypothesis and experimental design. 
If comparing between two groups, inspect if their distribution is normally distributed, and then apply a two-tailed 
two-sample unpaired t-test. 
The description of our analysis can be found in the Statistical Analysis section, as well as the legend of Figure 5 in 
our original manuscript (Le et al., 2021). 
 
For testing out the macro, please visit Anh Hoang Le’s Github page: 
https://github.com/AnhLe2702/20211019_MacroImageJ_Automatic_split_export_images and download two test 
image files, labelled scr_30_6.czi and 36_30_6.czi.  
 
 

https://github.com/AnhLe2702/20211019_MacroImageJ_Automatic_split_export_images
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Recipes 
 
1. PBS buffer 

1 L of PBS contains 10 PBS tablets in 1 L of distilled water. 
 

2. PE buffer 
5 L of PBS buffer, 1.86 g of EDTA. 
 

3. Growing DMEM medium 
500 mL of DMEM, 50 mL of serum, 5 mL of L-Glutamine, 5 mL of Penicillin-Streptomycin.  
 

4. Serum-free DMEM medium 
500 mL of DMEM, 5 mL of L-Glutamine, 5 mL of Penicillin-Streptomycin. 
 

5. 4% PFA solution 
10 mL of 16% PFA 
30 mL of PBS 

 
 

Acknowledgments 
 
We thank Cancer Research UK for core funding (A17196 and A31287) and funding to L.M. Machesky (A24452). 
The wet lab procedure was inspired by Commisso et al. (2014) and Anh H. Le et al. (2021). 
 
Le, A. H., Yelland, T., Paul, N. R., Fort, L., Nikolaou, S., Ismail, S. and Machesky, L. M. (2021). CYRI-A limits 
invasive migration through macropinosome formation and integrin uptake regulation. J Cell Biol 220(9).  
 
 

Competing interests 
 
The authors declare no competing interests.  
 
 

References 
 
Bloomfield, G. and Kay, R. R. (2016). Uses and abuses of macropinocytosis. J Cell Sci 129(14): 2697-2705.  
Commisso, C., Flinn, R. J. and Bar-Sagi, D. (2014). Determining the macropinocytic index of cells through a 

quantitative image-based assay. Nat Protoc 9(1): 182-192.  
Davidson, A. J. and Insall, R. H. (2011). Actin-based motility: WAVE regulatory complex structure reopens old 

SCARs. Curr Biol 21(2): R66-68.  
Goley, E. D. and Welch, M. D. (2006). The ARP2/3 complex: an actin nucleator comes of age. Nat Rev Mol Cell 

Biol 7(10): 713-726.  
Koivusalo, M., Welch, C., Hayashi, H., Scott, C. C., Kim, M., Alexander, T., Touret, N., Hahn, K. M. and Grinstein, 

S. (2010). Amiloride inhibits macropinocytosis by lowering submembranous pH and preventing Rac1 and 
Cdc42 signaling. J Cell Biol 188(4): 547-563.  

Krause, M. and Gautreau, A. (2014). Steering cell migration: lamellipodium dynamics and the regulation of 
directional persistence. Nat Rev Mol Cell Biol 15(9): 577-590.  

https://www.ncbi.nlm.nih.gov/pubmed/34165494
https://www.ncbi.nlm.nih.gov/pubmed/34165494
https://www.ncbi.nlm.nih.gov/pubmed/27352861
https://www.ncbi.nlm.nih.gov/pubmed/24385148
https://www.ncbi.nlm.nih.gov/pubmed/24385148
https://www.ncbi.nlm.nih.gov/pubmed/21256435
https://www.ncbi.nlm.nih.gov/pubmed/21256435
https://www.ncbi.nlm.nih.gov/pubmed/16990851
https://www.ncbi.nlm.nih.gov/pubmed/20156964
https://www.ncbi.nlm.nih.gov/pubmed/20156964
https://www.ncbi.nlm.nih.gov/pubmed/25145849
https://www.ncbi.nlm.nih.gov/pubmed/25145849


Cite as: Le, A. H. and Machesky, L. M. (2022). Image-based Quantification of Macropinocytosis Using Dextran Uptake 
into Cultured Cells. Bio-protocol 12(07): e4367. DOI: 10.21769/BioProtoc.4367. 

 

14 
 

 

Published:  Apr 05, 2022 

Le, A. H., Yelland, T., Paul, N. R., Fort, L., Nikolaou, S., Ismail, S. and Machesky, L. M. (2021). CYRI-A limits 
invasive migration through macropinosome formation and integrin uptake regulation. J Cell Biol 220(9): 
e202012114. 

Machacek, M., Hodgson, L., Welch, C., Elliott, H., Pertz, O., Nalbant, P., Abell, A., Johnson, G. L., Hahn, K. M. 
and Danuser, G. (2009). Coordination of Rho GTPase activities during cell protrusion. Nature 461(7260): 99-
103.  

Schindelin, J., Arganda-Carreras, I., Frise, E., Kaynig, V., Longair, M., Pietzsch, T., Preibisch, S., Rueden, C., 
Saalfeld, S., Schmid, B., et al., A. (2012). Fiji: an open-source platform for biological-image analysis. Nat 
Methods 9(7): 676-682.  

Swanson, J. A. and Watts, C. (1995). Macropinocytosis. Trends Cell Biol 5(11): 424-428.  
Theveneau, E. and Mayor, R. (2013). Collective cell migration of epithelial and mesenchymal cells. Cell Mol Life 

Sci 70(19): 3481-3492.  
 

https://www.ncbi.nlm.nih.gov/pubmed/34165494
https://www.ncbi.nlm.nih.gov/pubmed/34165494
https://www.ncbi.nlm.nih.gov/pubmed/19693013
https://www.ncbi.nlm.nih.gov/pubmed/22743772
https://www.ncbi.nlm.nih.gov/pubmed/14732047
https://www.ncbi.nlm.nih.gov/pubmed/23314710

