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INTRODUCTION 

The following User Guide shows how you can analyse data collected 
from the Health and Neighbourhood Mobility Survey. You can find 
the Health and Neighbourhood Mobility Survey questionnaire at 
www.ucl.ac.uk/street-mobility/toolkit. We have created a Microsoft 
Excel file as one way to handle the survey data. You can download 
this from the project website at www.ucl.ac.uk/street-mobility/toolkit. 

 

The following User Guide shows examples of how you can analyse 
the data from the Health and Neighbourhood Mobility Survey using 
pivot tables and charts in Microsoft Excel. This is not the only way to 
analyse the data, but it is simple and quick, so learning how to use 
pivot tables will probably save you time.1 

 

                                                             
1 This User Guide assumes some familiarity with Excel. A useful summary of basic tips to using Excel 2013 can 
be found here: www.siumed.edu/lib/classes/excel/Excel2013-Basics.pdf. This User Guide is designed for 
people using PCs. Some instructions would be different on a Mac. 

 

 

http://www.ucl.ac.uk/street-mobility/toolkit
http://www.ucl.ac.uk/street-mobility/toolkit
http://www.siumed.edu/lib/classes/excel/Excel2013-Basics.pdf
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THE HEALTH AND NEIGHBOURHOOD MOBILITY SURVEY DATABASE 

The Microsoft Excel file is a randomly generated database that contains responses from 100 
participants to the Health and Neighbourhood Mobility Survey, as an example. The Survey itself 
contains 14 questions covering topics such as: 

 demographics (gender, age, length of time lived at the address);  

 perceived health; and  

 travel and mobility (e.g. whether factors such as the speed of traffic, amount of traffic, or lack of 

crossing points affect walking around the local area).  

Some of the questions require only one answer. Other questions ask the survey respondent to tick all 
the response options that apply to them. 

In practice, we expect that you would manually enter the residents’ answers on the paper version of 
the questionnaire into a computer database such as Excel, giving each answer a numerical code, such 
as 0 for ‘No’ and 1 for ‘Yes’ for easier analysis.  

Below is a screen shot of the Excel file (worksheet titled “Raw-data”) that you can download 
from the Street Mobility Project website: 

 

The 14 questions in the Survey are arranged as separate columns in the Excel database: with a 
separate row for each participant (denoted by the respondent ID). Each participant has a unique 
identifier (column headed ID in this database). For example, the column headed Q1 contains the 
answers to the first question “Are you…” with the numerical codes 1 for ‘Male’ and 2 for ‘Female’. 
We used the numerical code -2 if participants did not tick either of the two boxes. This is important as 
you may prefer to exclude people with missing values from your statistical analysis.  
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Q3 in the Survey asked “How long have you lived at this address?” with separate boxes for years and 
months (if a participant lived at the address for less than one year). This has been arranged in the 
Excel database as two columns: Q3Y contains the number of years, and Q3M contains the number of 
months. Similarly, Q8 asks participants whether nine factors (e.g. speed of traffic, amount of traffic) 
“affect your ability to walk to places in your local area?” The answers for each factor (numerical codes: 
ranging from 1 for “Never” to 4 for “Always”) are arranged as nine columns (e.g. Q8A for the speed 
of traffic, and Q8B for the amount of traffic). We will be analysing this data later. 

In the remaining sections of this User Guide, we show examples of how to tabulate the data from the 
Health and Neighbourhood Mobility Survey using Pivot Tables2 and how you could show the results 
graphically.  

 

EXAMPLE 1: SIMPLE DESCRIPTIVE ANALYSIS 

Our first example shows how you can run a simple descriptive analysis. For example, you may want 
to know the age distribution of the participants in your survey (e.g. the percentage of participants 
who were aged 85 years and over). This can be shown in a frequency table3 and as a column chart. 

Frequency table 

To create a frequency table using pivot tables in Excel, in the worksheet containing the raw data, click 
on the Insert tab, and select PivotTable.  

 

In the Create PivotTable box, use the ‘Select a table or range’ option, and using the mouse on your 
computer highlight the whole survey data.   

                                                             
2 PivotTables are one way to summarise, analyse, explore, and present your data. They are highly flexible 
and can be adjusted quickly depending on how you need to display your results 
(https://support.office.com/en-gb/article/Create-a-PivotTable-to-analyze-worksheet-data-a9a84538-bfe9-
40a9-a8e9-f99134456576). 
 
3 A frequency table is a table that lists items and shows the number of times they occur. 

https://support.office.com/en-gb/article/Create-a-PivotTable-to-analyze-worksheet-data-a9a84538-bfe9-40a9-a8e9-f99134456576
https://support.office.com/en-gb/article/Create-a-PivotTable-to-analyze-worksheet-data-a9a84538-bfe9-40a9-a8e9-f99134456576
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Alternatively, you could select all the cells in the worksheet containing the survey data by clicking the 
Select All button in the top left corner of the worksheet (as below) and then click on the Insert tab, and 
select PivotTable : 

 

We also found that minor changes to road design could make walking trips much shorter and 
quicker, reduce the amount pedestrians are exposed to traffic, and could improve the quality of 
the street environment.4 

It is probably easier to choose to create your PivotTable report in a New Worksheet rather than in 
the Existing one. In the new worksheet, an option menu will appear on the right-hand side of the 
screen: the column names attached to the Survey questions will appear as tick boxes, and below there 

will be four boxes: Report Filter, Column Labels, Row Labels and Σ Values.  

You need to drag the chosen column headings into the boxes to create the PivotTable. In this example, 

we drag the column heading Q2 into the Row Labels box. In the Σ Values box, drag the column 

heading ID. We do not want the ‘Sum of ID number’ (which is the default setting). Choose the down 

arrow in the Σ Values box: select Value Field Settings: change Sum of ID to Count of ID in the option 

list (as shown below).  

 

 

                                                             
4 Anciaes PR, Jones P. The effectiveness of changes in street layout and design for reducing barriers to walking. 
Transportation Research Record 2016; 2586: 39-47. 
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The PivotTable Field List will then look like this: 
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The PivotTable created will then show the number of survey participants within each age-group 
category.5 To assign value labels within the PivotTable you can click on the cells of the Row Labels 
column in the PivotTable: e.g. replace 1 with ’18-24’, 2 with ’25-34’, and so on.  You should then have 
a PivotTable that looks something like this (showing, for example, that 21 of the 100 participants 
were in the 45-54 age-group): 

 

Showing percentages rather than frequency  

If you want to show the percentage of survey participants who belonged to each age-group then you 
could click in the “Count of ID” column, use right-click, and select “Show Values As -> % of Grand 
Total” (as shown below). Other summary statistics are available.6  

 

You can remove the missing values (coded in this example as -2) by clicking on the Row Labels down 
arrow in the PivotTable, and unchecking the -2 label (the percentages will then be recalculated 

                                                             
5 If you make a mistake creating a PivotTable report then click inside the PivotTable, click on the Options tab, 
choose “Select -> EntirePivotTable”, and then press delete. 
 
6 This table can be easily extended. For example, to obtain counts of the number of male and female 
participants in each age-group, drag the Q1 column heading into the Column Labels box. 
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excluding the missing data). Similarly, you could uncheck the row labelled “(blank”), which may 
appear7. 

Column chart 

Once you have the appropriate values in a PivotTable then you can consider using charts to show 
your findings graphically. To show the age distribution of the survey participants in a column chart you 
can highlight the whole PivotTable, click on the Insert tab, and select a Clustered Column Chart (2-D). 
You should then have a Chart that looks something like this: 

 

This chart shows that 22% of survey participants were aged 45-54: just over 5% of participants were 
aged 85 years and over. 

The grey boxes in this Chart can be removed by clicking on one of the grey boxes, using right-click, 
and then choosing the “Hide All Field Buttons on Chart” option. Of course, many formatting 
improvements can be made to this Chart (such as getting rid of the decimal points on the vertical axis), 
but these are beyond the scope of this User Guide.  

  

                                                             
7 The (blank) label may appear if earlier you selected all the cells in the “Raw-Data” worksheet by clicking the Select All 
button in the top left corner of the worksheet. 
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EXAMPLE 2: INDICATORS OF COMMUNITY SEVERANCE BY AGE-GROUP 

In this more complicated example we show how you can calculate and graphically show the responses 
to a question for survey participants in different categories. 

In this example, we are finding out the percentage of survey participants in each age-group who 
reported that their ability to walk to places in their local area was “Often” or “Always” affected by 
factors such as the speed or the amount of traffic. These indicators of the “barrier effect” of transport 
infrastructure or of motorised traffic were asked in Q8 of the Health and Neighbourhood Mobility 
Survey as follows: 

Survey question on barriers to walkability  

 

In this example, we focus on four of the community severance indicators:  

 amount of traffic (column Q8B in the Excel database);  

 crossings that do not allow adequate time to cross (column Q8D);  

 poor pavements or paths (column Q8F); and  

 air pollution (column Q8H).  

To show these results, we build on the earlier example. In the worksheet containing the raw data, click 
on the Insert tab, and select PivotTable. In the Create PivotTable box, use the ‘Select a table or range’ 
option, and using the mouse on your computer highlight the whole survey data.  
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We recommend as a simple first step creating four PivotTables within the same new Excel Worksheet: 
i.e. a separate PivotTable for each of the four indicators of community severance. For example, to 
create the PivotTable for the amount of traffic (Q8B), drag the column heading for age-group (Q2) 
into the Row Labels box, drag the column heading Q8B into the Column Labels box, and drag ID 

number into the Σ Values box. As before, we do not want the ‘Sum of ID number’ (the default). Choose 

the down arrow in the Σ Values box: select Value Field Settings: change Sum of ID to Count of ID in 

the option list (as shown below).  

 

Adding appropriate Row and Column Labels, excluding missing values8, and entering a title for the 
PivotTable, you could have a PivotTable that looks something like this: 

                                                             
8 Click on the Row Labels down arrow in the PivotTable, and uncheck the box containing the -2 Row Label; click 
on the Column Labels down arrow in the PivotTable, and uncheck the box which contains the -2 Column Label. 
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Then click on a cell within the same Excel Worksheet where it would be convenient to create a similar 
PivotTable for the barrier representing crossings that do not allow adequate time to cross (column 
Q8D). This cell would be the upper-left cell of the new PivotTable. Repeating this procedure, we 
would then have four separate PivotTables within the same Excel Worksheet that looks something like 
this:  

 

As mentioned earlier, we want to show the percentage of survey participants in each age-group who 
reported that their ability to walk to places in their local area was “Often” or “Always” affected by 
factors such as the speed or the amount of traffic. To achieve this, we must add the percentage of 
participants in the “Often” and “Always” columns. 

We can achieve this in the following three steps. 

First, we convert the cell counts in the four PivotTables to row percentages: by clicking in the cells of 
the PivotTable, use right-click, and select “Show Values As -> % of Row Total” (as shown below):  
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Showing percentages rather than frequency  

 

The first PivotTable would then look something like this: 

 

We can change the formatting to show the percentages to no decimal points by highlighting all the 
numbers in a PivotTable, right-click, select “Format Cells” and use the down arrow to show 0 decimal 
places (as shown below) and click OK. 
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Doing this separately for the four PivotTables, the Excel worksheet would then look something like this: 

 

Secondly, we need to add the percentages in the separate “Often” and “Always” columns. 
Unfortunately, this can be quite problematic due to the embedded formulae within the PivotTable.  
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Therefore, we recommend using Copy - Paste values to create a copy of each PivotTable before we 
do our adding up. Using this method, we want to copy the contents of a cell, but just want to paste the 
value and not the underlying formula that is displayed in the formula bar. 9  To do this: 

1. Highlight the whole PivotTable; 

2. Use copy (Ctrl-C10); 

3. Select on the upper-left cell of the paste area (where you want the new Table to go); and  

4. Right-click and then check the “paste values” box. 

Repeat this for the other three PivotTables.  

Then format each table to show as percentages with no decimal points (by highlighting all the 
numbers in the table, right-click, select “Format Cells” , choose the Percentage option, and use the 
down arrow to show 0 decimal places). 

The Excel worksheet would then look something like this (where the four created PivotTables are on 
the left-side of the worksheet, and the four copies are on the right-side): 

 

Finally, for summary purposes, we can then create our own table in Excel which shows the percentage 
of survey participants that were “Often” or “Always” affected by a particular barrier. To do this, 
using the tables we have just copied (i.e. the tables pasted with values, not formulas), we can 
calculate the relevant percentages for being “Often” or “Always” affected by a barrier.  

  

                                                             
9 A useful guide to this procedure can be found here: https://support.office.com/en-us/article/Paste-values-
not-formulas-12687B4D-C79F-4137-B0CC-947C229C55B9 . 
10 Press the C key when holding down the Ctrl key on your keyboard. 

https://support.office.com/en-us/article/Paste-values-not-formulas-12687B4D-C79F-4137-B0CC-947C229C55B9
https://support.office.com/en-us/article/Paste-values-not-formulas-12687B4D-C79F-4137-B0CC-947C229C55B9
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For example, within the same worksheet, we can create an empty table such as this: 

 

Within the cells of this table, we can use Excel’s built-in functions to add the appropriate percentages.  

For example, in the first row of the column headed Q8B, we can type in the cell  

= SUM(S5,T5) 

 and press return.  

In this example, S5 is the cell that contains the % of participants aged 18-24 who reported being 
“Often” affected by the volume of traffic; T5 is the cell that contains the % of participants aged 18-
24 who reported being “Always” affected by the volume of traffic. We used the SUM function to 
add these two %s. Repeating this for each PivotTable would give us the following: 

Using Excel’s built in functions to combine columns  
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For the first row of our Table the results would be as follows: 

 

Once we have the correct formula in place for each column we can then use Excel’s AUTOFILL function 
to fill cell content: this can save time, and minimise computing error, when you have content to enter 
that follows a repeatable pattern or sequence. 

More specifically, we can then take advantage of the Fill Handle in Excel: this is the little black 
square in the lower right-hand corner of the selected cell (as illustrated below)11:  

 

Having used the SUM formula for the first row in a column, move the cursor over the fill handle. The 
cursor becomes a black crosshair (+). Click and drag the fill handle down the column. The percentage 
of participants in each age-group who were “Often” or “Always” affected would then be calculated 
automatically. Then repeat this procedure for the other three columns. The results would be as follows: 

% of participants “Often” or “Always” affected by a particular barrier by age-group 

                                                             
11 More details on using autofill in Excel to fill cell content can be found here: 
www.siumed.edu/lib/classes/excel/Excel2013-Basics.pdf  

file:///C:/Users/rmjdshc/AppData/Local/Microsoft/Windows/Temporary%20Internet%20Files/Content.Outlook/6BBIYVA9/www.siumed.edu/lib/classes/excel/Excel2013-Basics.pdf
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Column char t 

Once you have the appropriate values in your own Excel Table then you can consider using a chart to 
graphically show your findings. To show the percentage of the survey participants who were “Often” 
or “Always” affected by the four chosen barriers separately by age-group you can highlight the 
whole Table, click on the Insert tab, and select a Clustered Column Chart (2-D). After some formatting 
improvements, you could then have a Chart that looks something like this: 
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EXAMPLE 3: INDICATORS OF COMMUNITY SEVERANCE BY MOBILITY 
LIMITATION 

In this final example we show how you can calculate and graphically show the percentage of survey 
participants with and without a mobility limitation (Q7 in the Survey) who reported that barriers such 
as the speed or the amount of traffic were “Often” or “Always” a problem on the busiest road in the 
local area. These potential “barrier effects” are asked in Q9 of the Health and Neighbourhood 
Mobility Survey as follows: 

Survey question on problems on the busiest road  

 

In this example, we focus on each potential “barrier effect”.  The results will be compared for the two 
groups of participants: those with and without a mobility limitation.  

To show these results, we build on the earlier examples.  

The first step is to create a separate PivotTable for each “barrier effect”. As before, drag the 
relevant column heading for the barrier effect into the Column Labels box, drag the column for 
mobility limitations (column Q7 in the Excel database) into the Row Labels box, and drag the column 

heading ID into the Σ Values box. We do not want the ‘Sum of ID number’ (which is the default 

setting). Choose the down arrow in the Σ Values box: select Value Field Settings: change Sum of ID to 

Count of ID in the option list. 

After adding appropriate Row and Column Labels, excluding missing values, and entering a title for 
each PivotTable, the same Excel Worksheet containing the nine separate PivotTables would look 
something like this: 
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The second step is to convert the cell counts in the nine PivotTables to row percentages. As in the 
earlier example, click in the cells of the PivotTable, use right-click, and select “Show Values As -> % 
of Row Total”. Change the formatting to show percentages to no decimal points by highlighting all the 
numbers in a PivotTable, right-click, select “Format Cells” and use the down arrow to show 0 decimal 
places. 

Doing this separately for the nine PivotTables, the Excel worksheet would then look something like this: 
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We are then able to add the percentages in the separate “Often” and “Always” columns. As in the 
earlier example, this is easier to do by using Copy – Paste values to create a copy of each 
PivotTable before we do our adding up. For each PivotTable: 

1. Highlight the whole PivotTable; 

2. Use copy (Ctrl-C12); 

3. Select on the upper-left cell of the paste area (where you want the new Table to go); and  

4. Right-click and then check the “paste values” box. 

Then format each table to show as percentages with no decimal points (by highlighting all the 
numbers in the table, right-click, select “Format Cells” , choose the Percentage option, and use the 
down arrow to show 0 decimal places). 

The Excel worksheet would then look something like this (where the original created PivotTables are 
on the left-side of the worksheet, and the copies are on the right-side): 

 

Finally, for summary purposes, we can then create our own table in Excel which shows the percentage 
of survey participants with and without a mobility limitation who were “Often” or “Always” affected 
by a particular problem on the busiest road in their area. To do this, using the tables we have just 
copied, we can calculate the relevant percentages for being “Often” or “Always” affected by a 
barrier. 

  

                                                             
12 Press the C key when holding down the Ctrl key on your keyboard. 
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For example, within the same Excel worksheet, we can create an empty table such as this: 

 

Within the cells of this table, we can use Excel’s built-in functions to add the appropriate percentages. 
In the first row of the column Q9A, type in the cell: 

= SUM(R5,S5) 

and press return.  

In this example, R5 is the cell that contains the % of participants with a mobility limitation who 
reported being “Often” affected by the speed of traffic on the busiest road in their area; S5 is the 
cell that contains the % of participants with a mobility limitation who reported being “Always” 
affected by the speed of traffic on the busiest road in their area.  

As before, we then use Excel’s AUTOFILL function (the Fill Handle) to calculate the result for the 
participants who did not report a mobility limitation. Having used a formula for the first row in a 
column (the group with a mobility limitation), move the cursor over the fill handle. The cursor becomes 
a black crosshair (+). Click and drag the fill handle down the column. The percentage of participants 
who did not report a mobility limitation that were “Often” or “Always” affected by the speed of 
traffic on the busiest road would then be calculated automatically.  

Then repeat this procedure for the other “barrier effects”. The results would be as follows: 

% of participants “Often” or “Always” affected by a particular barrier on the busiest road by 
mobility limitation 

 

Bar char t 

To show the percentage of the survey participants who were “Often” or “Always” affected by the 
potential barriers on the busiest road separately for participants with and without a mobility 
limitation you can highlight the whole Table, click on the Insert tab, and select a Bar Chart. After some 
formatting improvements, you could then have a chart that looks something like this: 

 


